Ubuntu 18.04 出现“launchpadlib 1.10.6 requires testresources, which is not installed.” 的解决方法

搬瓦工

今天装 Python 库的时候遇到一个问题,记录一下解决方法。提示 “launchpadlib 1.10.6 requires testresources, which is not installed.” ,其实解决也简单,把缺少的东西装上就行。听说潘石屹都开始学 Python 了,你们还不赶紧学习起来吗。

一、解决方法

尝试下面指令:

apt search testresources
apt search widgetsnbextension

如果上面的输出结果没有你想装的,那么使用下面的命令开始安装:

sudo apt install python3-widgetsnbextension
sudo apt install python3-testresources

如果再次错误,使用 apt search 再次搜索。

二、参考文献和其他

参考:https://github.com/pypa/pip/issues/5372

本站会慢慢多整理一些遇到的 Python 相关问题的解决方法。同时也欢迎大家购买一台 BandwagonHost VPS 进行实践。参考《搬瓦工 VPS(BandwagonHost)所有便宜方案整理和推荐》。

赞(0)
未经允许不得转载:老唐博客 » Ubuntu 18.04 出现“launchpadlib 1.10.6 requires testresources, which is not installed.” 的解决方法

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址