在 Ubuntu 16.04 LTS 系统上安装 Python 3.6

文章目录

Ubuntu 16.04 LTS 系统默认自带的是 Python 2.7 和 Python 3.5,有时候我们会需要用到 Python 3.6,但是官方的源里是没有 Python 3.6 的 ,今天就介绍一下如何安装 Python 3.6。

安装方法

1. 配置软件仓库,因为 Python 3.6 新版没有发布到 Ubuntu 的正式仓库中,咱们通过第3方仓库来做。在命令行中输入:

sudo add-apt-repository ppa:jonathonf/python-3.6

如果有提示信息,回车即可。

2. 检查系统软件包并安装 Python 3.6

sudo apt-get update 
sudo apt-get install python3.6

3. 查看 Python 版本信息(现在在你的系统中已经有3个 Python 版本了)

python -V
python3 -V
python3.6 -V

4. 通过上图我们看到,新安装的3.6版本需要输入 python3.6 才能使用,那能不能配置我只输入 python3 时就默认使用 3.6 版本呢,当然可以,执行以下命令:

sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.5 1 
sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.6 2 
sudo update-alternatives --config python3

5. 最后再确认一下:

python3 -V

6. 配置完成后,之前有些 3.5 版本时候装的包可能会提示不存在了,此时重新安装一下即可。

参考文章

https://blog.csdn.net/lzzyok/article/details/77413968

未经允许不得转载:老唐博客 » 在 Ubuntu 16.04 LTS 系统上安装 Python 3.6

赞 (0)

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址